Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi
  • Page :
  • 1
  • 2

SUJET : Squash TM Service is running but not accessing

Squash TM Service is running but not accessing il y a 2 semaines 2 jours #7826

  • HUSSNAIN
  • Portrait de HUSSNAIN
  • Hors Ligne
  • Fresh Boarder
  • Messages : 6
Hello,

I have installed Squash TM on Linux Centos 7. It was working perfectly before couple of days ago but now its not working. Squash service is running but unable to access via IP and Port

Telnet to squash custom port also refusing

Please help

Thank You
Pièces jointes :
L'administrateur a désactivé l'accès en écriture pour le public.

Squash TM Service is running but not accessing il y a 2 semaines 2 jours #7828

  • Alexandre
  • Portrait de Alexandre
  • Hors Ligne
  • Administrator
  • Messages : 42
  • Remerciements reçus 10
Hello,

where (in which file) did you change squash-tm listening port ?
Can you check open ports on your machine (run ss -ltn for instance) ?
L'administrateur a désactivé l'accès en écriture pour le public.

Squash TM Service is running but not accessing il y a 2 semaines 2 jours #7833

  • HUSSNAIN
  • Portrait de HUSSNAIN
  • Hors Ligne
  • Fresh Boarder
  • Messages : 6
Hi Alexandre,

Thanks for your reply.

I had set port 3000 for squash TM. It was working before and then it stopped working with port 3000 so I just changed port to 8000 and its not working now. After some time service gets stopped and when I start services its doesn't telnet to 8000.

I changed the port in "/etc/sysconfig/squash-tm" file. But its not working





Could you please help me
L'administrateur a désactivé l'accès en écriture pour le public.

Squash TM Service is running but not accessing il y a 2 semaines 2 jours #7834

  • HUSSNAIN
  • Portrait de HUSSNAIN
  • Hors Ligne
  • Fresh Boarder
  • Messages : 6
I have restarted service again but ss- ltn not showing port open 8000
L'administrateur a désactivé l'accès en écriture pour le public.

Squash TM Service is running but not accessing il y a 2 semaines 2 jours #7835

  • Alexandre
  • Portrait de Alexandre
  • Hors Ligne
  • Administrator
  • Messages : 42
  • Remerciements reçus 10
HUSSNAIN écrit:
I have restarted service again but ss- ltn not showing port open 8000

What is it showing, then ?

Do you have a (reverse) proxy somewhere between client and squash ?
Can you try the following command on squash machine ?
for port in 3000 8000 8080 ; do wget http://localhost:${port}/squash ; done
L'administrateur a désactivé l'accès en écriture pour le public.

Squash TM Service is running but not accessing il y a 2 semaines 2 jours #7836

  • HUSSNAIN
  • Portrait de HUSSNAIN
  • Hors Ligne
  • Fresh Boarder
  • Messages : 6
I have changed the port of SQUASH TM to 3000. I have also installed Xwiki/Bugzilla/ on server please check follow links. I have set reverse proxy for Xwiki and Bugzilla and both are working fine. But squash TM is causing issue. I have disabled proxy settings for Squash TM in Apache. But it should connect to port 3000 locally first. Also Squash service automatically stopped after sometime

Here are your command logs


-2019-03-06 16:00:42-- http://localhost:3000/squash
Resolving localhost (localhost)... 127.0.0.1
Connecting to localhost (localhost)|127.0.0.1|:3000... failed: Connection refused.
--2019-03-06 16:00:42-- http://localhost:8000/squash
Resolving localhost (localhost)... 127.0.0.1
Connecting to localhost (localhost)|127.0.0.1|:8000... failed: Connection refused.
--2019-03-06 16:00:42-- http://localhost:8080/squash
Resolving localhost (localhost)... 127.0.0.1
Connecting to localhost (localhost)|127.0.0.1|:8080... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://localhost:8080/users/sign_in [following]
--2019-03-06 16:00:49-- http://localhost:8080/users/sign_in
Connecting to localhost (localhost)|127.0.0.1|:8080... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: âsquashâ

[ <=> ] 10,399 --.-K/s in 0s

2019-03-06 16:00:49 (139 MB/s) - âsquashâ saved [10399]




URLs:

5.189.179.250:8080
5.189.179.250:8090
L'administrateur a désactivé l'accès en écriture pour le public.

Squash TM Service is running but not accessing il y a 2 semaines 2 jours #7837

  • HUSSNAIN
  • Portrait de HUSSNAIN
  • Hors Ligne
  • Fresh Boarder
  • Messages : 6
Please go through Squash-tm Logs
L'administrateur a désactivé l'accès en écriture pour le public.

Squash TM Service is running but not accessing il y a 2 semaines 2 jours #7838

  • Alexandre
  • Portrait de Alexandre
  • Hors Ligne
  • Administrator
  • Messages : 42
  • Remerciements reçus 10
Indeed.
It may be related to your firewall.
To check this, can you try do disable temporariliy your firewall (systemctl stop firewalld), then try to access squash-tm, and then restart your firewall (systemctl start firewalld)
Or do the following:
firewall-cmd --permanent --add-port=3000/tcp
firewall-cmd --reload
And then try again to access squash-tm
L'administrateur a désactivé l'accès en écriture pour le public.

Squash TM Service is running but not accessing il y a 2 semaines 2 jours #7839

  • HUSSNAIN
  • Portrait de HUSSNAIN
  • Hors Ligne
  • Fresh Boarder
  • Messages : 6
Hello Alexandre,

Hope you are doing great!


Thank you for your reply. Well I have already disabled firewall but unfortunately not getting through. I dnt know why its happening, other applications are working properly.Looks like there is some issue with Squash-tm service because after sometime the service gets stopped.

Could you please review the above attached logs so that we could dig out more.
L'administrateur a désactivé l'accès en écriture pour le public.

Squash TM Service is running but not accessing il y a 2 semaines 1 jour #7841

  • Alexandre
  • Portrait de Alexandre
  • Hors Ligne
  • Administrator
  • Messages : 42
  • Remerciements reçus 10
HUSSNAIN écrit:
Could you please review the above attached logs so that we could dig out more.

Hello,

I can't find your logs in this thread, are you sure you attached them ?
L'administrateur a désactivé l'accès en écriture pour le public.

Squash TM Service is running but not accessing il y a 2 semaines 1 jour #7843

  • Hussnain Toufiq
  • Portrait de Hussnain Toufiq
  • Hors Ligne
  • Fresh Boarder
  • Messages : 3
Please find the attached latest squash-tm logs. Its still not working. I dnt know why its service getting stopped

Fichier attaché :

Nom du fichier : squash-tm.zip
Taille du ficher :63 ko
L'administrateur a désactivé l'accès en écriture pour le public.

Squash TM Service is running but not accessing il y a 2 semaines 1 jour #7844

  • Alexandre
  • Portrait de Alexandre
  • Hors Ligne
  • Administrator
  • Messages : 42
  • Remerciements reçus 10
Indeed, it seems there is a problem with squash-tm connection to its H2 database.
We will try to reproduce this, can you specify your JRE version (java -version) and your squash-tm version ?

(Also, please note that H2 database is manly for testing purpose, we recommend using mysql/mariadb/postgresql instead)
L'administrateur a désactivé l'accès en écriture pour le public.
  • Page :
  • 1
  • 2
Temps de génération de la page : 0.178 secondes